summaryrefslogtreecommitdiff
path: root/binutils/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-25 20:39:41 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-25 20:39:41 +0000
commit506eb5219ebf3275c7e5e679c698d0cf29bf3d96 (patch)
treebe7395fe3b7fe87e861bac8dcfffc860da7bc9b2 /binutils/Makefile.am
parent214ce7b58a5e6526bd9fcfe7e7893e2b915f75fd (diff)
binutils: fix out of tree building with syslex regens
If you take a release tarball (which has pregenerated syslex and sysinfo files in it), apply some patches which touch syslex.l, and then build the result out of tree, it will fail. This is because syslex.l uses sysinfo.h, but the sysinfo.y file wasn't updated and so it wasn't regenerated (the files are found in the $srcdir), and the build rule for syslex.c does not use -I$(srcdir) when it finds a local file. Simple fix below. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'binutils/Makefile.am')
-rw-r--r--binutils/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/binutils/Makefile.am b/binutils/Makefile.am
index bbe58e2132..59f759fcce 100644
--- a/binutils/Makefile.am
+++ b/binutils/Makefile.am
@@ -272,7 +272,7 @@ sysinfo$(EXEEXT_FOR_BUILD): sysinfo.@OBJEXT@ syslex.@OBJEXT@
syslex.@OBJEXT@: syslex.c sysinfo.h config.h
if [ -r syslex.c ]; then \
- $(CC_FOR_BUILD) -c -I. $(AM_CFLAGS) $(CFLAGS_FOR_BUILD) $(NO_WERROR) syslex.c ; \
+ $(CC_FOR_BUILD) -c -I. -I$(srcdir) $(AM_CFLAGS) $(CFLAGS_FOR_BUILD) $(NO_WERROR) syslex.c ; \
else \
$(CC_FOR_BUILD) -c -I. -I$(srcdir) $(AM_CFLAGS) $(CFLAGS_FOR_BUILD) $(NO_WERROR) $(srcdir)/syslex.c ;\
fi