summaryrefslogtreecommitdiff
path: root/binutils/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2009-06-04 06:56:53 +0000
committerAlan Modra <amodra@gmail.com>2009-06-04 06:56:53 +0000
commit4b9d2a998bc949c056e4a37f0942e3ea0571376a (patch)
treef8d6306566a5a3822270f9691632af24e5f5facf /binutils/Makefile.am
parenta1ef399e234ed22e6594a0622362a4c1a26b8967 (diff)
* dep-in.sed: Don't use \n in replacement part of s command.
* Makefile.am (DEP1): LC_ALL for uniq. Run "make dep-am". * Makefile.in: Regenerate.
Diffstat (limited to 'binutils/Makefile.am')
-rw-r--r--binutils/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/binutils/Makefile.am b/binutils/Makefile.am
index 535e556221..d3dd46eb8b 100644
--- a/binutils/Makefile.am
+++ b/binutils/Makefile.am
@@ -411,7 +411,8 @@ DEP1: $(CFILES) $(GENERATED_CFILES)
for f in $?; do \
$(MKDEP) $(INCLUDES) $(CFLAGS) $$f > DEPA; \
sed -n -e '1s/: .*/: \\/p' -e q < DEPA >> DEP2; \
- sed -e '1s/.*: //' -f dep.sed < DEPA | LC_ALL=C sort | uniq | \
+ sed -e '1s/.*: //' -f dep.sed < DEPA | \
+ LC_ALL=C sort | LC_ALL=C uniq | \
sed -e 's/^[AB]/ /' -e '$$s/ \\$$//' >> DEP2; \
done
rm -f DEPA
@@ -496,6 +497,7 @@ addr2line.o: \
ar.o: \
ar.c \
$(BFDDIR)/libbfd.h \
+ $(BFDDIR)/plugin.h \
$(INCDIR)/alloca-conf.h \
$(INCDIR)/ansidecl.h \
$(INCDIR)/aout/ar.h \
@@ -764,6 +766,7 @@ nlmconv.o: \
nm.o: \
nm.c \
$(BFDDIR)/elf-bfd.h \
+ $(BFDDIR)/plugin.h \
$(INCDIR)/alloca-conf.h \
$(INCDIR)/ansidecl.h \
$(INCDIR)/aout/ranlib.h \