summaryrefslogtreecommitdiff
path: root/bfd/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2017-08-30 19:55:45 -0700
committerH.J. Lu <hjl.tools@gmail.com>2017-08-30 19:55:45 -0700
commit3321e42bf2b5819b76ca36e8964fe7cf9a8ae9a2 (patch)
treeb00656df7b1b0caa61fb8aa18ed29cd799f54b91 /bfd/configure.ac
parent59e8523bf8f92db8371d3a10bd7e4d7fe03d417d (diff)
Add elf64.lo together with elfxx-x86.lo for 64-bit BFD
Since elfxx-x86.lo needs elf64.lo with 64-bit BFD, add elf64.lo together with elfxx-x86.lo to bfd_backends for 64-bit BFD. * configure.ac (bfd_backends): Add elf64.lo together with elfxx-x86.lo for 64-bit BFD. * configure: Regenerated.
Diffstat (limited to 'bfd/configure.ac')
-rw-r--r--bfd/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/bfd/configure.ac b/bfd/configure.ac
index 0e4c669b7d..3f2cedfd63 100644
--- a/bfd/configure.ac
+++ b/bfd/configure.ac
@@ -825,6 +825,13 @@ case ${host64}-${target64}-${want64} in
;;
esac
+# elfxx-x86.lo needs elf64.lo with 64-bit BFD.
+case "${bfd_backends}-${wordsize}" in
+ *elfxx-x86.lo*-64*)
+ bfd_backends="${bfd_backends} elf64.lo"
+ ;;
+esac
+
tdefaults=""
test -n "${defvec}" && tdefaults="${tdefaults} -DDEFAULT_VECTOR=${defvec}"
test -n "${selvecs}" && tdefaults="${tdefaults} -DSELECT_VECS='${selvecs}'"