summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-03 18:22:46 +0100
committerQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-03 18:35:20 +0100
commitb26e9a8eda6552b8a5cbc24bbc584049e4761962 (patch)
treeaa534b673ea66d88caef42b1438c0f74114347ef
parent4315935baf52bf37fd075e6a55700abf0fd5607a (diff)
kernel: linux: linux-tsd: add support for Haikou Video Demo adapter on Puma
Our vendor Linux kernel tree v6.0.2 and later supports Haikou Video Demo adapter on Haikou devkit with a RK3399-Q7 Puma fitted. Therefore, let's add its Device Tree to the list of Device Tree to include in the package. Furthermore, make it the default Device Tree by adding in first position. It does not hurt to use this by default since it'll impair nothing from the original devkit if absent and allows for a more featureful default. Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>
-rw-r--r--recipes-kernel/linux/linux-tsd_6.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-tsd_6.0.bb b/recipes-kernel/linux/linux-tsd_6.0.bb
index c0f75c8..743081a 100644
--- a/recipes-kernel/linux/linux-tsd_6.0.bb
+++ b/recipes-kernel/linux/linux-tsd_6.0.bb
@@ -34,6 +34,8 @@ LINUX_VERSION ?= "6.0.2"
DEFCONFIG:ringneck-haikou ?= "ringneck-px30_defconfig"
DEFCONFIG:puma-haikou ?= "puma-rk3399_defconfig"
+KERNEL_DEVICETREE:prepend:puma-haikou = "rockchip/rk3399-puma-haikou-video-demo.dtb "
+
# Borrowed from kernel-yocto.bbclass:do_kernel_metadata()
do_configure:prepend () {
if [ -n "${DEFCONFIG}" ]; then