summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-03 18:11:51 +0100
committerQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-03 18:35:17 +0100
commit9030006fb75e2344b28c51986f057d904fa3ec2c (patch)
treea354bdc45eb7137027b244e08a93a539cf9f8e53
parent4bd68c59e109de8fea2cfcd3047d6916439bda47 (diff)
kernel: linux: linux-tsd: add Puma support
RK3399-Q7 Puma SoM is now supported on our custom v6.0.2 so let's add it to the linux-tsd recipe for v6.0 kernel branch. Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>
-rw-r--r--recipes-kernel/linux/linux-tsd_6.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-tsd_6.0.bb b/recipes-kernel/linux/linux-tsd_6.0.bb
index f2ce785..c0f75c8 100644
--- a/recipes-kernel/linux/linux-tsd_6.0.bb
+++ b/recipes-kernel/linux/linux-tsd_6.0.bb
@@ -10,10 +10,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
inherit kernel
SRC_GIT_REPO:ringneck-haikou = "git://git.theobroma-systems.com/ringneck-linux.git"
+SRC_GIT_REPO:puma-haikou = "git://git.theobroma-systems.com/puma-linux.git"
SRC_GIT_REPO_PROTO = ";protocol=https"
SRC_GIT_BRANCH:ringneck-haikou = ";branch=v6.0.2-ringneck"
+SRC_GIT_BRANCH:puma-haikou = ";branch=v6.0.2-puma"
-COMPATIBLE_MACHINE = "ringneck-haikou"
+COMPATIBLE_MACHINE = "(puma-haikou|ringneck-haikou)"
SRC_URI = " \
${SRC_GIT_REPO}${SRC_GIT_REPO_PROTO}${SRC_GIT_BRANCH} \
@@ -21,6 +23,7 @@ SRC_URI = " \
"
SRCREV:ringneck-haikou = "de748a4593915b3566233e6724bac9ecb4418e38"
+SRCREV:puma-haikou = "7624b244784bd19b4f5100a94ea3ac2bb1f3624d"
S = "${WORKDIR}/git"
@@ -29,6 +32,7 @@ SRC_URI_PATCHES ?= ""
LINUX_VERSION ?= "6.0.2"
DEFCONFIG:ringneck-haikou ?= "ringneck-px30_defconfig"
+DEFCONFIG:puma-haikou ?= "puma-rk3399_defconfig"
# Borrowed from kernel-yocto.bbclass:do_kernel_metadata()
do_configure:prepend () {