summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-03 18:10:04 +0100
committerQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-03 18:10:04 +0100
commit4bd68c59e109de8fea2cfcd3047d6916439bda47 (patch)
tree1b26969d9894e2a83c93182516caeffbf3b56c34
parent761a5b59fdf274ba3099dc0d22ac38b27a410837 (diff)
kernel: linux: linux-tsd: prepare for new board support
In preparation for a new board support, let's make the current variables board-specific wherever appropriate. Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>
-rw-r--r--recipes-kernel/linux/linux-tsd_6.0.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-tsd_6.0.bb b/recipes-kernel/linux/linux-tsd_6.0.bb
index d3e3119..f2ce785 100644
--- a/recipes-kernel/linux/linux-tsd_6.0.bb
+++ b/recipes-kernel/linux/linux-tsd_6.0.bb
@@ -9,16 +9,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
inherit kernel
-SRC_GIT_REPO = "git://git.theobroma-systems.com/ringneck-linux.git"
+SRC_GIT_REPO:ringneck-haikou = "git://git.theobroma-systems.com/ringneck-linux.git"
SRC_GIT_REPO_PROTO = ";protocol=https"
-SRC_GIT_BRANCH = ";branch=v6.0.2-ringneck"
+SRC_GIT_BRANCH:ringneck-haikou = ";branch=v6.0.2-ringneck"
+
+COMPATIBLE_MACHINE = "ringneck-haikou"
SRC_URI = " \
${SRC_GIT_REPO}${SRC_GIT_REPO_PROTO}${SRC_GIT_BRANCH} \
${SRC_URI_PATCHES} \
"
-SRCREV = "de748a4593915b3566233e6724bac9ecb4418e38"
+SRCREV:ringneck-haikou = "de748a4593915b3566233e6724bac9ecb4418e38"
S = "${WORKDIR}/git"
@@ -26,7 +28,7 @@ SRC_URI_PATCHES ?= ""
LINUX_VERSION ?= "6.0.2"
-DEFCONFIG ?= "ringneck-px30_defconfig"
+DEFCONFIG:ringneck-haikou ?= "ringneck-px30_defconfig"
# Borrowed from kernel-yocto.bbclass:do_kernel_metadata()
do_configure:prepend () {