summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-06 10:47:55 +0000
committerQuentin Schulz <quentin.schulz@theobroma-systems.com>2023-02-06 10:47:55 +0000
commit02fff9caa789c8f414581e95b393bfde17f1a5d3 (patch)
tree474ec077b427a3f3da55e1e98869093c87d3d1af
parent761a5b59fdf274ba3099dc0d22ac38b27a410837 (diff)
parent8c9a9b47b6a0ade31c741bb9c1fd8440b858c6be (diff)
Merge branch 'dev/puma-6.0.2' into 'kirkstone'
Linux kernel v6.0.2 for Puma See merge request som/yocto-layers/meta-theobroma-systems-bsp!19
-rw-r--r--conf/machine/puma-haikou.conf3
-rw-r--r--recipes-kernel/linux/linux-tsd_6.0.bb16
2 files changed, 15 insertions, 4 deletions
diff --git a/conf/machine/puma-haikou.conf b/conf/machine/puma-haikou.conf
index 83878be..e516425 100644
--- a/conf/machine/puma-haikou.conf
+++ b/conf/machine/puma-haikou.conf
@@ -19,6 +19,8 @@ MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
PREFERRED_VERSION_linux-yocto = "5.10%"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-tsd"
PREFERRED_PROVIDER_u-boot = "u-boot-tsd"
+PREFERRED_PROVIDER_virtual/kernel = "linux-tsd"
+PREFERRED_VERSION_linux-tsd = "6.0"
##############################################################
# Rockchip Android 4.4 vendor kernel configuration/selection #
@@ -26,6 +28,7 @@ PREFERRED_PROVIDER_u-boot = "u-boot-tsd"
# Uncomment the next few variables to use Rockchip Android 4.4 vendor kernel
#PREFERRED_PROVIDER_virtual/kernel = "linux-tsd"
+#PREFERRED_VERSION_linux-tsd = "4.4%"
#KERNEL_DEVICETREE = "rockchip/rk3399-puma.dtb"
# The following few variables are required because the fitImage for some reasons
diff --git a/recipes-kernel/linux/linux-tsd_6.0.bb b/recipes-kernel/linux/linux-tsd_6.0.bb
index d3e3119..db9bc26 100644
--- a/recipes-kernel/linux/linux-tsd_6.0.bb
+++ b/recipes-kernel/linux/linux-tsd_6.0.bb
@@ -9,16 +9,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
inherit kernel
-SRC_GIT_REPO = "git://git.theobroma-systems.com/ringneck-linux.git"
+SRC_GIT_REPO:ringneck-haikou = "git://git.theobroma-systems.com/ringneck-linux.git"
+SRC_GIT_REPO:puma-haikou = "git://git.theobroma-systems.com/puma-linux.git"
SRC_GIT_REPO_PROTO = ";protocol=https"
-SRC_GIT_BRANCH = ";branch=v6.0.2-ringneck"
+SRC_GIT_BRANCH:ringneck-haikou = ";branch=v6.0.2-ringneck"
+SRC_GIT_BRANCH:puma-haikou = ";branch=v6.0.2-puma"
+
+COMPATIBLE_MACHINE = "(puma-haikou|ringneck-haikou)"
SRC_URI = " \
${SRC_GIT_REPO}${SRC_GIT_REPO_PROTO}${SRC_GIT_BRANCH} \
${SRC_URI_PATCHES} \
"
-SRCREV = "de748a4593915b3566233e6724bac9ecb4418e38"
+SRCREV:ringneck-haikou = "805aa082cec9a41c51e8af36c5092495e37388da"
+SRCREV:puma-haikou = "7624b244784bd19b4f5100a94ea3ac2bb1f3624d"
S = "${WORKDIR}/git"
@@ -26,7 +31,10 @@ SRC_URI_PATCHES ?= ""
LINUX_VERSION ?= "6.0.2"
-DEFCONFIG ?= "ringneck-px30_defconfig"
+DEFCONFIG:ringneck-haikou ?= "ringneck-px30_defconfig"
+DEFCONFIG:puma-haikou ?= "puma-rk3399_defconfig"
+
+KERNEL_DEVICETREE:prepend:puma-haikou = "rockchip/rk3399-puma-haikou-video-demo.dtb "
# Borrowed from kernel-yocto.bbclass:do_kernel_metadata()
do_configure:prepend () {