summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskander Amara <iskander.amara@theobroma-systems.com>2024-03-15 11:48:14 +0100
committerQuentin Schulz <quentin.schulz@theobroma-systems.com>2024-03-25 15:36:00 +0000
commitb6fde515c58941e8d1540d411934f1fb8f24e4e6 (patch)
tree0ccc921b5c1b1bc9b77e76f13cf45b38ff066c67
parentdb7d7df3c078dd495acb8ef7300e61ddcc6d4c58 (diff)
add initial support for TIGER SOM-RK3588-Q7HEADkirkstone
This Adds support for TIGER SOM-RK3588-Q7: - Vendor Linux kernel: 5.10 - U-Boot bootloader are based on 2017.09 Relates-to: TIGR-5 Signed-off-by: Iskander Amara <iskander.amara@theobroma-systems.com>
-rw-r--r--.gitlab-ci.yml3
-rw-r--r--README3
-rw-r--r--conf/machine/tiger-haikou.conf38
-rw-r--r--recipes-bsp/u-boot/u-boot-tsd_2017.09.bb5
-rw-r--r--recipes-kernel/linux/linux-tsd_5.10.bb6
5 files changed, 53 insertions, 2 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 24f5969..b526f5e 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -51,3 +51,6 @@ puma-haikou:
jaguar:
extends: .build
+
+tiger-haikou:
+ extends: .build \ No newline at end of file
diff --git a/README b/README
index 345bf0d..b775ec4 100644
--- a/README
+++ b/README
@@ -28,6 +28,9 @@ builds and boots wic image:
https://www.theobroma-systems.com/som-product/px30-uq7/
jaguar
https://www.theobroma-systems.com/product/jaguar-sbc-rk3588
+ tiger-haikou
+ https://www.theobroma-systems.com/evaluationkit/haikou-q7-dev-kit/
+ https://www.theobroma-systems.com/product/tiger-som-rk3588-q7/
Maintainer
==========
diff --git a/conf/machine/tiger-haikou.conf b/conf/machine/tiger-haikou.conf
new file mode 100644
index 0000000..2e3b4bc
--- /dev/null
+++ b/conf/machine/tiger-haikou.conf
@@ -0,0 +1,38 @@
+#@TYPE: Machine
+#@NAME: TIGER SOM-RK3588-Q7
+#@DESCRIPTION: Theobroma Systems SOM-RK3588-Q7 (TIGER)
+# See:
+# https://theobroma-systems.com/product/tiger-som-rk3588-q7/
+
+require conf/machine/include/rk3588.inc
+
+# Manage Tiger haikou supported DTBs
+KERNEL_DEVICETREE = " \
+rockchip/rk3588-tiger-haikou.dtb \
+rockchip/rk3588-tiger-haikou-video-demo.dtb \
+rockchip/rk3588-tiger-haikou-video-demo-q7-camera-demo-cam0-cam1-hdmi.dtb \
+"
+
+UBOOT_MACHINE = "tiger-rk3588_defconfig"
+
+IMAGE_FSTYPES += "wic wic.bmap"
+
+SERIAL_CONSOLES = "115200;ttyS2"
+
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-tsd"
+PREFERRED_VERSION_linux-tsd = "5.10%"
+PREFERRED_PROVIDER_u-boot = "u-boot-tsd"
+PREFERRED_VERSION_u-boot-tsd = "2017.09"
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot-tsd"
+# The following few variables are required because Rockchip's U-Boot is somehow
+# not capable of booting standard fitImages. Once upstream U-Boot is supported,
+# this can be removed.
+# Only the filename is kept, nothing else from the path since the
+# DTBs are copied directly to /boot without a parent subdirectory.
+KERNEL_DEVICETREE_FILENAME = "${@' '.join(os.path.basename(dtb) for dtb in d.getVar('KERNEL_DEVICETREE').split())}"
+IMAGE_BOOT_FILES = "Image ${KERNEL_DEVICETREE_FILENAME}"
+KERNEL_IMAGETYPE = "Image"
+# First DTS in KERNEL_DEVICETREE is used as default DTS in U-Boot.
+UBOOT_DEFAULT_FDT_FILE = "${@d.getVar('KERNEL_DEVICETREE_FILENAME').split()[0]}"
diff --git a/recipes-bsp/u-boot/u-boot-tsd_2017.09.bb b/recipes-bsp/u-boot/u-boot-tsd_2017.09.bb
index 9916372..9d2d0be 100644
--- a/recipes-bsp/u-boot/u-boot-tsd_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-tsd_2017.09.bb
@@ -4,8 +4,10 @@ require recipes-bsp/u-boot/u-boot.inc
#DEPENDS += "bc-native dtc-native python3-setuptools-native"
SRC_GIT_REPO:jaguar = "git://git.theobroma-systems.com/jaguar-u-boot.git"
+SRC_GIT_REPO:tiger-haikou = "git://git.theobroma-systems.com/tiger-u-boot.git"
SRC_GIT_REPO_PROTO = ";protocol=https"
SRC_GIT_BRANCH:jaguar = ";branch=linux-5.10-gen-rkr4.1-jaguar"
+SRC_GIT_BRANCH:tiger-haikou = ";branch=linux-5.10-gen-rkr4.1-tiger"
SRC_URI_PATCHES = ""
@@ -20,12 +22,13 @@ DEPENDS += "bc-native"
DEPENDS += "dtc-native"
SRCREV:jaguar = "a247cbf1129d9b79e1d388a3da13464c92768378"
+SRCREV:tiger-haikou = "a83570fa629b19bb3a06b69f1e56ee957b8921f5"
PROVIDES += "u-boot"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-COMPATIBLE_MACHINE = "(jaguar)"
+COMPATIBLE_MACHINE = "(jaguar|tiger-haikou)"
UBOOT_MAKE_TARGET = "spl/u-boot-spl.bin u-boot.dtb u-boot.itb"
diff --git a/recipes-kernel/linux/linux-tsd_5.10.bb b/recipes-kernel/linux/linux-tsd_5.10.bb
index 5375cbd..ac271fc 100644
--- a/recipes-kernel/linux/linux-tsd_5.10.bb
+++ b/recipes-kernel/linux/linux-tsd_5.10.bb
@@ -10,10 +10,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
inherit kernel
SRC_GIT_REPO:jaguar = "git://git.theobroma-systems.com/jaguar-linux.git"
+SRC_GIT_REPO:tiger-haikou = "git://git.theobroma-systems.com/tiger-linux.git"
SRC_GIT_REPO_PROTO = ";protocol=https"
SRC_GIT_BRANCH:jaguar = ";branch=linux-5.10-gen-rkr4.1-jaguar"
+SRC_GIT_BRANCH:tiger-haikou = ";branch=linux-5.10-gen-rkr4.1-tiger"
-COMPATIBLE_MACHINE = "(jaguar)"
+COMPATIBLE_MACHINE = "(jaguar|tiger-haikou)"
SRC_URI = " \
${SRC_GIT_REPO}${SRC_GIT_REPO_PROTO}${SRC_GIT_BRANCH} \
@@ -21,6 +23,7 @@ SRC_URI = " \
"
SRCREV:jaguar = "a68cba5c49103c73efda209185f38c08b6d23dce"
+SRCREV:tiger-haikou = "bb63edc4488927cba484b66e2be4d59c10604e17"
S = "${WORKDIR}/git"
@@ -29,6 +32,7 @@ SRC_URI_PATCHES ?= ""
LINUX_VERSION ?= "5.10.160"
DEFCONFIG:jaguar ?= "jaguar-rk3588_defconfig"
+DEFCONFIG:tiger-haikou ?= "tiger-rk3588_defconfig"
CONFIGURE_FILES = "${DEFCONFIG}"