summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-09-22 11:06:18 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-09-22 20:04:53 +0200
commit39e7c72aa56c5805e268f4661ca236f0487854d9 (patch)
tree031aab275634f89b8960ee4aba2f93c435c0d941
parentc1230b289af24de139556ae9ca980ee3b4ff6eb5 (diff)
package/policycoreutils: drop host-python(3) dependency for host-policycoreutils
Since SELinux 2.7, the python tools that used to be in policycoreutils have been moved into a separate package, called "python" in upstream SELinux, and "selinux-python" in Buildroot. Therefore, we can drop the host-python(3) dependency from host-policycoreutils. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--package/policycoreutils/policycoreutils.mk12
1 files changed, 0 insertions, 12 deletions
diff --git a/package/policycoreutils/policycoreutils.mk b/package/policycoreutils/policycoreutils.mk
index b117aa6902..4f7176777c 100644
--- a/package/policycoreutils/policycoreutils.mk
+++ b/package/policycoreutils/policycoreutils.mk
@@ -73,22 +73,10 @@ HOST_POLICYCOREUTILS_MAKE_OPTS = \
$(HOST_CONFIGURE_OPTS) \
CFLAGS="$(HOST_CFLAGS) -U_FILE_OFFSET_BITS" \
CPPFLAGS="$(HOST_CPPFLAGS) -U_FILE_OFFSET_BITS" \
- PYTHON="$(HOST_DIR)/bin/python" \
- PYTHON_INSTALL_ARGS="$(HOST_PKG_PYTHON_DISTUTILS_INSTALL_OPTS)" \
ARCH="$(HOSTARCH)" \
DESTDIR=$(HOST_DIR) \
PREFIX=$(HOST_DIR)
-ifeq ($(BR2_PACKAGE_PYTHON3),y)
-HOST_POLICYCOREUTILS_DEPENDENCIES += host-python3
-HOST_POLICYCOREUTILS_MAKE_OPTS += \
- PYLIBVER="python$(PYTHON3_VERSION_MAJOR)"
-else
-HOST_POLICYCOREUTILS_DEPENDENCIES += host-python
-HOST_POLICYCOREUTILS_MAKE_OPTS += \
- PYLIBVER="python$(PYTHON_VERSION_MAJOR)"
-endif
-
# Note: We are only building the programs required by the refpolicy build
HOST_POLICYCOREUTILS_MAKE_DIRS = \
load_policy newrole run_init \