summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKlaus Goger <klaus.goger@theobroma-systems.com>2018-05-22 10:25:37 +0200
committerChristoph Muellner <christoph.muellner@theobroma-systems.com>2019-08-14 14:22:02 +0200
commitfc8cc894be9338adb4ad91e395e5b76c84cca37b (patch)
tree98b19387bd8ddde73c3ccf5361ee961b6e383656
parent03c15b6ad10640a30296913bc61adcdf171b85df (diff)
boot: Add package rk3399-cortexm0-firmware.
On the RK3399 additional FW is required for certain tasks (e.g. standby-functionality). This firware will be run by the on-chip Cortex-M0 core, which is powered by a dedicated power domain, which can remain active when the system is in a low-power mode. The code for the FW is open-source, but a complete integration into Buildroot would have a too high impact on the build time (we have a Cortex-M0 toolchain as build dependency). Therefore this package just downloads the prebuilt binary. Signed-off-by: Klaus Goger <klaus.goger@theobroma-systems.com> Signed-off-by: Christoph Muellner <christoph.muellner@theobroma-systems.com>
-rw-r--r--boot/Config.in1
-rw-r--r--boot/rk3399-cortexm0-firmware/Config.in8
-rw-r--r--boot/rk3399-cortexm0-firmware/rk3399-cortexm0.mk20
3 files changed, 29 insertions, 0 deletions
diff --git a/boot/Config.in b/boot/Config.in
index 97bd3de6e9..225516d45b 100644
--- a/boot/Config.in
+++ b/boot/Config.in
@@ -16,6 +16,7 @@ source "boot/mxs-bootlets/Config.in"
source "boot/optee-os/Config.in"
source "boot/opensbi/Config.in"
source "boot/riscv-pk/Config.in"
+source "boot/rk3399-cortexm0-firmware/Config.in"
source "boot/s500-bootloader/Config.in"
source "boot/shim/Config.in"
source "boot/syslinux/Config.in"
diff --git a/boot/rk3399-cortexm0-firmware/Config.in b/boot/rk3399-cortexm0-firmware/Config.in
new file mode 100644
index 0000000000..9dc5d7d22f
--- /dev/null
+++ b/boot/rk3399-cortexm0-firmware/Config.in
@@ -0,0 +1,8 @@
+config BR2_TARGET_RK3399_CORTEXM0_FIRMWARE
+ bool "RK3399 Cortex-M0 firmware"
+ depends on BR2_aarch64 && BR2_TARGET_UBOOT && BR2_TARGET_ARM_TRUSTED_FIRMWARE
+ help
+ Enable this option if you want to build the Cortex-M0 formware
+ for your RK3399 based embedded device.
+
+ https://git.theobroma-systems.com/rk3399-cortex-m0.git
diff --git a/boot/rk3399-cortexm0-firmware/rk3399-cortexm0.mk b/boot/rk3399-cortexm0-firmware/rk3399-cortexm0.mk
new file mode 100644
index 0000000000..39afcc0710
--- /dev/null
+++ b/boot/rk3399-cortexm0-firmware/rk3399-cortexm0.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# rk3399-cortex-m0 firmware
+#
+################################################################################
+
+RK3399_CORTEXM0_FIRMWARE_SITE = https://git.theobroma-systems.com/rk3399-cortex-m0-binaries.git
+RK3399_CORTEXM0_FIRMWARE_SITE_METHOD = git
+RK3399_CORTEXM0_FIRMWARE_VERSION = 0119a4a8890c7b9a024a002e261cdd453ec23a65
+RK3399_CORTEXM0_FIRMWARE_LICENSE = BSD-3-Clause
+RK3399_CORTEXM0_FIRMWARE_LICENSE_FILES = license.rst
+
+
+RK3399_CORTEXM0_FIRMWARE_INSTALL_IMAGES = YES
+
+define RK3399_CORTEXM0_FIRMWARE_INSTALL_IMAGES_CMDS
+ cp -dpf $(@D)/rk3399m0.bin $(BINARIES_DIR)/
+endef
+
+$(eval $(generic-package))