summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Muellner <christoph.muellner@theobroma-systems.com>2019-08-14 14:20:19 +0200
committerChristoph Muellner <christoph.muellner@theobroma-systems.com>2019-08-14 19:14:11 +0200
commit95f85d17dc0f107add974ac0df30354347074046 (patch)
tree343b2c1f51273ea48b0bc103705224ec13879c92
parentfc8cc894be9338adb4ad91e395e5b76c84cca37b (diff)
uboot: Add Puma specific instructions.
To build mainline U-Boot for RK3399-Q7 (Puma), we need to copy the Cortex-M0 firmware to the build directory before building U-Boot. This patch allows to enable this step. Signed-off-by: Christoph Muellner <christoph.muellner@theobroma-systems.com>
-rw-r--r--boot/uboot/Config.in6
-rw-r--r--boot/uboot/uboot.mk8
2 files changed, 14 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 4edc490ded..0c39a7557e 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -553,4 +553,10 @@ config BR2_TARGET_UBOOT_CUSTOM_DTS_PATH
endif
+config BR2_TARGET_UBOOT_PUMA
+ bool "RK3399-Q7 specific bootloader steps"
+ default y if BR2_TARGET_UBOOT_VERSION = "puma-v2019.04"
+ help
+ Enable this option to include build steps required for the RK3399-Q7.
+
endif # BR2_TARGET_UBOOT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 408d27c2ac..cb222aa6ec 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -169,6 +169,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_LZOP),y)
UBOOT_DEPENDENCIES += host-lzop
endif
+ifeq ($(BR2_TARGET_UBOOT_PUMA),y)
+UBOOT_DEPENDENCIES += rk3399-cortexm0-firmware
+endif
+
# prior to u-boot 2013.10 the license info was in COPYING. Copy it so
# legal-info finds it
define UBOOT_COPY_OLD_LICENSE_FILE
@@ -254,6 +258,10 @@ endif # BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY
UBOOT_CUSTOM_DTS_PATH = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_DTS_PATH))
define UBOOT_BUILD_CMDS
+ $(if $(BR2_TARGET_UBOOT_PUMA),
+ cp -f $(BINARIES_DIR)/rk3399m0.bin $(@D)/rk3399m0.bin
+ cp -f $(BINARIES_DIR)/bl31.bin $(@D)/bl31-rk3399.bin
+ )
$(if $(UBOOT_CUSTOM_DTS_PATH),
cp -f $(UBOOT_CUSTOM_DTS_PATH) $(@D)/arch/$(UBOOT_ARCH)/dts/
)