summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 50dc98a8121..9bee504efec 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -19,11 +19,12 @@ endif()
# Set the depends list as a variable so that it can grow conditionally.
# NOTE: Sync the substitutions in test/lit.cfg when adding to this list.
set(LLVM_TEST_DEPENDS
- llvm-config
- UnitTests
BugpointPasses
+ FileCheck
LLVMHello
+ UnitTests
bugpoint
+ count
llc
lli
lli-child-target
@@ -31,6 +32,7 @@ set(LLVM_TEST_DEPENDS
llvm-as
llvm-bcanalyzer
llvm-c-test
+ llvm-config
llvm-cov
llvm-cxxdump
llvm-diff
@@ -54,14 +56,13 @@ set(LLVM_TEST_DEPENDS
llvm-split
llvm-symbolizer
llvm-tblgen
- opt
- FileCheck
- count
not
- yaml-bench
- yaml2obj
obj2yaml
+ opt
+ sancov
verify-uselistorder
+ yaml-bench
+ yaml2obj
)
# If Intel JIT events are supported, depend on a tool that tests the listener.