summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index a155cacb75b..3f9febc385a 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -73,6 +73,12 @@ else() # if this is included from LLVM's CMake
string(REPLACE "-" "_" canon_name ${projName})
string(TOUPPER ${canon_name} canon_name)
list(APPEND prefixes ${canon_name})
+
+ string(FIND ${projName} "lib" LIB_IDX)
+ if(LIB_IDX EQUAL 0)
+ string(SUBSTRING ${projName} 3 -1 projName)
+ endif()
+ list(APPEND runtime_names ${projName})
endforeach()
if(runtimes)
@@ -85,6 +91,7 @@ else() # if this is included from LLVM's CMake
# Builtins were built separately above
CMAKE_ARGS -DCOMPILER_RT_BUILD_BUILTINS=Off
PASSTHROUGH_PREFIXES ${prefixes}
+ EXTRA_TARGETS ${runtime_names}
USE_TOOLCHAIN)
endif()
endif()