summaryrefslogtreecommitdiff
path: root/lib/DebugInfo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/DebugInfo/CMakeLists.txt')
-rw-r--r--lib/DebugInfo/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/DebugInfo/CMakeLists.txt b/lib/DebugInfo/CMakeLists.txt
new file mode 100644
index 00000000000..446b8d6b15f
--- /dev/null
+++ b/lib/DebugInfo/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_llvm_library(LLVMMC
+ DIContext.cpp
+ DWARFAbbreviationDeclaration.cpp
+ DWARFCompileUnit.cpp
+ DWARFContext.cpp
+ DWARFDebugAbbrev.cpp
+ DWARFDebugInfoEntry.cpp
+ DWARFFormValue.cpp
+ )
+
+add_llvm_library_dependencies(LLVMDebugInfo
+ LLVMSupport
+ )