summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d08fd67ddaf..76d66b99fc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -845,7 +845,6 @@ if( LLVM_INCLUDE_UTILS )
add_subdirectory(utils/PerfectShuffle)
add_subdirectory(utils/count)
add_subdirectory(utils/not)
- add_subdirectory(utils/llvm-lit)
add_subdirectory(utils/yaml-bench)
else()
if ( LLVM_INCLUDE_TESTS )
@@ -932,6 +931,11 @@ endif()
add_subdirectory(cmake/modules)
+# Do this last so that all lit targets have already been created.
+if (LLVM_INCLUDE_UTILS)
+ add_subdirectory(utils/llvm-lit)
+endif()
+
if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
install(DIRECTORY include/llvm include/llvm-c
DESTINATION include