summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorPavel Labath <labath@google.com>2017-12-07 10:54:23 +0000
committerPavel Labath <labath@google.com>2017-12-07 10:54:23 +0000
commitb9b4df7d228873b4ed71c585af6de41232a8a3d2 (patch)
tree5d683daffbb696c2618f97e57e77870cf3a5ffa8 /unittests/Support/CMakeLists.txt
parent06535b0f5a25e8e0d4220993ad2de5a0132cbbab (diff)
[Testing/Support] Make matchers work with Expected<T&>
Summary: This did not work because the ExpectedHolder was trying to hold the value in an Optional<T*>. Instead of trying to mimic the behavior of Expected and try to make ExpectedHolder work with references and non-references, I simply store the reference to the Expected object in the holder. I also add a bunch of tests for these matchers, which have helped me flesh out some problems in my initial implementation of this patch, and uncovered the fact that we are not consistent in quoting our values in the matcher output (which I also fix). Reviewers: zturner, chandlerc Subscribers: mgorny, llvm-commits Differential Revision: https://reviews.llvm.org/D40904 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@320025 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index 24500e66ae7..299106e0dbf 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -68,6 +68,8 @@ add_llvm_unittest(SupportTests
xxhashTest.cpp
)
+target_link_libraries(SupportTests PRIVATE LLVMTestingSupport)
+
# Disable all warning for AlignOfTest.cpp,
# as it does things intentionally, and there is no reliable way of
# disabling all warnings for all the compilers by using pragmas.