summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <rnk@google.com>2017-05-17 18:16:17 +0000
committerReid Kleckner <rnk@google.com>2017-05-17 18:16:17 +0000
commitaabc86087d1dea46fc5f9bc2a3849303c56a42cc (patch)
treed564121866476ee54effea1c3c7eda98ad83448e /unittests/Support/CMakeLists.txt
parent10c594e32079cf76a9405c8f26cf23126acbcdc5 (diff)
Re-land r303274: "[CrashRecovery] Use SEH __try instead of VEH when available"
We have to check gCrashRecoveryEnabled before using __try. In other words, SEH works too well and we ended up recovering from crashes in implicit module builds that we weren't supposed to. Only libclang is supposed to enable CrashRecoveryContext to allow implicit module builds to crash. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@303279 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index f8d3c1c9a8c..e7f2f515d76 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -11,6 +11,7 @@ add_llvm_unittest(SupportTests
BlockFrequencyTest.cpp
BranchProbabilityTest.cpp
CachePruningTest.cpp
+ CrashRecoveryTest.cpp
Casting.cpp
Chrono.cpp
CommandLineTest.cpp