summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Karpenkov <ekarpenkov@apple.com>2018-03-02 00:30:43 +0000
committerGeorge Karpenkov <ekarpenkov@apple.com>2018-03-02 00:30:43 +0000
commita8353210f0513b2a3bcfb547cc20432e17b8da5c (patch)
tree70ff53f1e25486d132e638843bfe456fc2469a61 /unittests/Support/CMakeLists.txt
parent185ee30a67bdb75a316ac64d706f45d36b961297 (diff)
Utility functions for checked arithmetic
Provide checkedAdd and checkedMul functions, providing checked arithmetic on signed integers. Differential Revision: https://reviews.llvm.org/D43704 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@326516 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index 1eb3a04d91d..89e16ef4b3f 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -13,6 +13,7 @@ add_llvm_unittest(SupportTests
CachePruningTest.cpp
CrashRecoveryTest.cpp
Casting.cpp
+ CheckedArithmeticTest.cpp
Chrono.cpp
CommandLineTest.cpp
CompressionTest.cpp