summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-06-14 22:33:43 +0000
committerZachary Turner <zturner@google.com>2017-06-14 22:33:43 +0000
commit458f91302fed48bb8112a033b56dff8ef8eb1a9a (patch)
tree551e0560dac4e5fb514a144f17419fcd4ae0a804 /unittests/Support/CMakeLists.txt
parentbe884e2441246e731f6e424b94522276d360fd48 (diff)
Don't include TestingSupport in LLVM_LINK_COMPONENTS.
Instead use target_link_libraries directly. Thanks to Juergen Ributzka for the suggestion, which fixes an issue when llvm is configured with no targets. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@305421 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index 348ffba95f2..e2a6561089b 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -1,6 +1,5 @@
set(LLVM_LINK_COMPONENTS
Support
- TestingSupport
)
add_llvm_unittest(SupportTests
@@ -73,6 +72,6 @@ add_llvm_unittest(SupportTests
set_source_files_properties(AlignOfTest.cpp PROPERTIES COMPILE_FLAGS -w)
# ManagedStatic.cpp uses <pthread>.
-target_link_libraries(SupportTests ${LLVM_PTHREAD_LIB})
+target_link_libraries(SupportTests LLVMTestingSupport ${LLVM_PTHREAD_LIB})
add_subdirectory(DynamicLibrary)