summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2017-03-16 03:42:00 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2017-03-16 03:42:00 +0000
commit2995c258a52f633ca698c10f832744e3f151d38f (patch)
treeada61a3ef06ad4207afe4bee32ded1612be04c49 /unittests/Support/CMakeLists.txt
parente6f1b022bf56b6d9be48d36b2e602be56e831971 (diff)
Support: Add a cache pruning policy parser.
The idea is that the policy string fully specifies the policy and is portable between clients. Differential Revision: https://reviews.llvm.org/D31020 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@297927 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index ed84ee9c2ef..a7be18b6a3c 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -10,6 +10,7 @@ add_llvm_unittest(SupportTests
BinaryStreamTest.cpp
BlockFrequencyTest.cpp
BranchProbabilityTest.cpp
+ CachePruningTest.cpp
Casting.cpp
Chrono.cpp
CommandLineTest.cpp