summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2018-06-25 03:13:09 +0000
committerZachary Turner <zturner@google.com>2018-06-25 03:13:09 +0000
commit19eaf65da0f221d137b44ed6859873a9b31e2da9 (patch)
treef7685d541686e26f367ca1c1d46df0471e3a96e3 /unittests/Support/CMakeLists.txt
parentad04e25e240fee87d8aa34e3328baa071ef7fabc (diff)
Add a TaskQueue that can serialize work on a ThreadPool.
We have ThreadPool, which can execute work asynchronously on N background threads, but sometimes you need to make sure the work is executed asynchronously but also serially. That is, if task B is enqueued after task A, then task B should not begin until task A has completed. This patch adds such a class. Differential Revision: https://reviews.llvm.org/D48240 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@335440 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index 4b46387a471..655ca7fb9b4 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -53,6 +53,7 @@ add_llvm_unittest(SupportTests
SwapByteOrderTest.cpp
TarWriterTest.cpp
TargetParserTest.cpp
+ TaskQueueTest.cpp
ThreadLocalTest.cpp
ThreadPool.cpp
Threading.cpp