summaryrefslogtreecommitdiff
path: root/tools/yaml2obj/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2017-01-12 21:35:21 +0000
committerChris Bieneman <beanz@apple.com>2017-01-12 21:35:21 +0000
commit15135b3b8a902f25418958ad9915e6962203bfe8 (patch)
tree91dbbba5a49510041d2fa7ff3b191aedb55c7959 /tools/yaml2obj/CMakeLists.txt
parentf6fc33e0fd84cc720fabb0723d4a1ebe901e438d (diff)
[ObjectYAML] Pull yaml2dwarf out of yaml2obj for reuse
This patch pulls the yaml2dwarf code out of yaml2obj into a new set of DWARF emitter functions in the DWARFYAML namespace. This will enable the YAML->DWARF code to be used inside DWARF tests by populating the DWARFYAML structs and calling the Emitter functions. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@291828 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/yaml2obj/CMakeLists.txt')
-rw-r--r--tools/yaml2obj/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/tools/yaml2obj/CMakeLists.txt b/tools/yaml2obj/CMakeLists.txt
index 5e726496003..885a69f5d3c 100644
--- a/tools/yaml2obj/CMakeLists.txt
+++ b/tools/yaml2obj/CMakeLists.txt
@@ -8,7 +8,6 @@ set(LLVM_LINK_COMPONENTS
add_llvm_tool(yaml2obj
yaml2obj.cpp
yaml2coff.cpp
- yaml2dwarf.cpp
yaml2elf.cpp
yaml2macho.cpp
)