summaryrefslogtreecommitdiff
path: root/tools/llvm-cfi-verify/CMakeLists.txt
diff options
context:
space:
mode:
authorVlad Tsyrklevich <vlad@tsyrklevich.net>2017-10-10 20:59:08 +0000
committerVlad Tsyrklevich <vlad@tsyrklevich.net>2017-10-10 20:59:08 +0000
commitf4ea125f2dbb0f430e5e0d058405844c11955c46 (patch)
tree7fed36c90175163a1dce6a75e325f89c31057a81 /tools/llvm-cfi-verify/CMakeLists.txt
parent2788c957a5553b63a02bc480aae3832773696e5a (diff)
Classify llvm-cfi-verify.
Summary: Move llvm-cfi-verify into a class in preparation for CFI analysis to come. Reviewers: vlad.tsyrklevich Reviewed By: vlad.tsyrklevich Subscribers: mgorny, llvm-commits, pcc, kcc Differential Revision: https://reviews.llvm.org/D38379 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@315363 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-cfi-verify/CMakeLists.txt')
-rw-r--r--tools/llvm-cfi-verify/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/llvm-cfi-verify/CMakeLists.txt b/tools/llvm-cfi-verify/CMakeLists.txt
index d6dce723aaf..ff7d7b92f4e 100644
--- a/tools/llvm-cfi-verify/CMakeLists.txt
+++ b/tools/llvm-cfi-verify/CMakeLists.txt
@@ -13,4 +13,5 @@ set(LLVM_LINK_COMPONENTS
add_llvm_tool(llvm-cfi-verify
llvm-cfi-verify.cpp
+ FileAnalysis.cpp
)