summaryrefslogtreecommitdiff
path: root/tools/llvm-c-test/CMakeLists.txt
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2017-11-01 22:18:52 +0000
committerwhitequark <whitequark@whitequark.org>2017-11-01 22:18:52 +0000
commit8b4e833a6e12d6bc11d3f5802ddcec657dc9205e (patch)
tree2c4735dbf198468c856b94b435da3959b58fc014 /tools/llvm-c-test/CMakeLists.txt
parent01dd53d4bd9f4e9a14e1bf1c037df9c90522d464 (diff)
[LLVM-C] Expose functions to create debug locations via DIBuilder.
These include: * Several functions for creating an LLVMDIBuilder, * LLVMDIBuilderCreateCompileUnit, * LLVMDIBuilderCreateFile, * LLVMDIBuilderCreateDebugLocation. Patch by Harlan Haskins. Differential Revision: https://reviews.llvm.org/D32368 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@317135 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-c-test/CMakeLists.txt')
-rw-r--r--tools/llvm-c-test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/llvm-c-test/CMakeLists.txt b/tools/llvm-c-test/CMakeLists.txt
index a2bde0d9714..bce0f4a5a42 100644
--- a/tools/llvm-c-test/CMakeLists.txt
+++ b/tools/llvm-c-test/CMakeLists.txt
@@ -38,6 +38,7 @@ endif ()
add_llvm_tool(llvm-c-test
attributes.c
calc.c
+ debuginfo.c
diagnostic.c
disassemble.c
echo.cpp