summaryrefslogtreecommitdiff
path: root/tools/llvm-c-test/CMakeLists.txt
diff options
context:
space:
mode:
authorAmaury Sechet <deadalnix@gmail.com>2016-02-04 23:26:19 +0000
committerAmaury Sechet <deadalnix@gmail.com>2016-02-04 23:26:19 +0000
commit88242800f7c1b6d73142ebdf9f4ca58845c81882 (patch)
tree29491cb3ee7c16b61c954c46a9184cac4b2644de /tools/llvm-c-test/CMakeLists.txt
parente0a5f73cd5e9d432f88e6c3f0fb933f4c6c9764a (diff)
Improve testing for the C API
Summary: This basically add an echo test case in C. The support is limited right now, but full support would just be too much to review at once. The echo test case simply get a module as input and try to output the same exact module. This allow to check the both reading and writing API are working as expected. I want to improve this test over time to support more and more of the API, in order to improve coverage (coverage is quite poor right now). Test Plan: Run the test. Reviewers: chandlerc, bogner Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D10725 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@259844 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-c-test/CMakeLists.txt')
-rw-r--r--tools/llvm-c-test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/llvm-c-test/CMakeLists.txt b/tools/llvm-c-test/CMakeLists.txt
index f22dffb30e8..405dc3df4ee 100644
--- a/tools/llvm-c-test/CMakeLists.txt
+++ b/tools/llvm-c-test/CMakeLists.txt
@@ -37,6 +37,7 @@ endif ()
add_llvm_tool(llvm-c-test
calc.c
disassemble.c
+ echo.cpp
helpers.c
include-all.c
main.c