summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-07-19 23:51:13 +0000
committerPetr Hosek <phosek@chromium.org>2017-07-19 23:51:13 +0000
commit98f9792e7ca5bbd9eb43bda72bf497957cfb6eb8 (patch)
treea780486563bf0c4c1321227c7dafcc6cf6b8430b /test/CMakeLists.txt
parent0775d243ea9b6d8593cfe5619c8df6327fd9276a (diff)
[LLVM][llvm-objcopy] Added basic plumbing to get things started
As discussed on llvm-dev I've implemented the first basic steps towards llvm-objcopy/llvm-objtool (name pending). This change adds the ability to copy (without modification) 64-bit little endian ELF executables that have SHT_PROGBITS, SHT_NOBITS, SHT_NULL and SHT_STRTAB sections. Patch by Jake Ehrlich Differential Revision: https://reviews.llvm.org/D33964 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@308559 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 124f0c72fd7..ab5c7031bfb 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -61,6 +61,7 @@ set(LLVM_TEST_DEPENDS
llvm-modextract
llvm-mt
llvm-nm
+ llvm-objcopy
llvm-objdump
llvm-opt-report
llvm-pdbutil