summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Aizatsky <aizatsky@chromium.org>2015-11-12 19:34:21 +0000
committerMike Aizatsky <aizatsky@chromium.org>2015-11-12 19:34:21 +0000
commit91e7b1246cbbcb7b16624788dd6e313d59d988bc (patch)
treee6d6c5e916712235eb1e16f4b82acfc0e8f0bf51 /test/CMakeLists.txt
parent8e6493db9162d4143f8a129ac25d345e0b91e62f (diff)
sancov test suite
Differential Revision: http://reviews.llvm.org/D14589 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@252933 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 50dc98a8121..9bee504efec 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -19,11 +19,12 @@ endif()
# Set the depends list as a variable so that it can grow conditionally.
# NOTE: Sync the substitutions in test/lit.cfg when adding to this list.
set(LLVM_TEST_DEPENDS
- llvm-config
- UnitTests
BugpointPasses
+ FileCheck
LLVMHello
+ UnitTests
bugpoint
+ count
llc
lli
lli-child-target
@@ -31,6 +32,7 @@ set(LLVM_TEST_DEPENDS
llvm-as
llvm-bcanalyzer
llvm-c-test
+ llvm-config
llvm-cov
llvm-cxxdump
llvm-diff
@@ -54,14 +56,13 @@ set(LLVM_TEST_DEPENDS
llvm-split
llvm-symbolizer
llvm-tblgen
- opt
- FileCheck
- count
not
- yaml-bench
- yaml2obj
obj2yaml
+ opt
+ sancov
verify-uselistorder
+ yaml-bench
+ yaml2obj
)
# If Intel JIT events are supported, depend on a tool that tests the listener.