summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Clegg <sbc@chromium.org>2017-10-18 19:37:30 +0000
committerSam Clegg <sbc@chromium.org>2017-10-18 19:37:30 +0000
commit88d22be42ce67c9c1a54981a23e7869c3279c3cb (patch)
tree881f6b4881de21a41c36f64ea4b555edd90a4d93 /test/CMakeLists.txt
parent4a5c81f50fa0d545a499b1fa12e7feefbf6f9976 (diff)
Don't set static-libs test feature when using LLVM_LINK_LLVM_DYLIB
This was causing execname-options.ll to fail on the wasm waterfall. Differential Revision: https://reviews.llvm.org/D39022 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@316123 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 33e5da0eb1b..efb43955d57 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -8,7 +8,9 @@ llvm_canonicalize_cmake_booleans(
HAVE_LIBXAR
LLVM_ENABLE_DIA_SDK
LLVM_ENABLE_FFI
- BUILD_SHARED_LIBS)
+ BUILD_SHARED_LIBS
+ LLVM_LINK_LLVM_DYLIB
+ )
configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.py.in