summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Gorny <mgorny@gentoo.org>2017-01-06 21:33:54 +0000
committerMichal Gorny <mgorny@gentoo.org>2017-01-06 21:33:54 +0000
commit4d3523945dee825652d127c9b81dcc37980cbf29 (patch)
tree037cd0438b73489fcb17aca96b6324080aaf9e3b /test/CMakeLists.txt
parent1159e421994d6bab805683f41a069e9189ed2ac4 (diff)
[llvm-config] Print --system-libs only when static linking
Modify the --system-libs option in llvm-config to print system libs only when using static linking. The system libraries are irrelevant when linking to a shared library since the library has appropriate library dependencies embedded. Modify the --system-libs test appropriately to force static linking, and disable it if static libs are not available (i.e. BUILD_SHARED_LIBS is enabled). Differential Revision: https://reviews.llvm.org/D27805 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@291285 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3bef0209620..c1667049f80 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -7,7 +7,8 @@ llvm_canonicalize_cmake_booleans(
HAVE_LIBZ
HAVE_LIBXAR
LLVM_ENABLE_DIA_SDK
- LLVM_ENABLE_FFI)
+ LLVM_ENABLE_FFI
+ BUILD_SHARED_LIBS)
configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.in