summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-07-21 23:27:40 +0000
committerPetr Hosek <phosek@chromium.org>2017-07-21 23:27:40 +0000
commit2f423248e140b94b8377660d4d2fe9364f30febe (patch)
tree543752ab648ed257dca7e98905216aa836c45087 /test/CMakeLists.txt
parentcc55cc245165b76a065f79b097391a1734dbe169 (diff)
Reland "[LLVM][llvm-objcopy] Added basic plumbing to get things started"
As discussed on llvm-dev I've implemented the first basic steps towards llvm-objcopy/llvm-objtool (name pending). This change adds the ability to copy (without modification) 64-bit little endian ELF executables that have SHT_PROGBITS, SHT_NOBITS, SHT_NULL and SHT_STRTAB sections. Patch by Jake Ehrlich Differential Revision: https://reviews.llvm.org/D33964 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@308803 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 124f0c72fd7..ab5c7031bfb 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -61,6 +61,7 @@ set(LLVM_TEST_DEPENDS
llvm-modextract
llvm-mt
llvm-nm
+ llvm-objcopy
llvm-objdump
llvm-opt-report
llvm-pdbutil