summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-08-26 20:34:11 +0000
committerChris Bieneman <beanz@apple.com>2016-08-26 20:34:11 +0000
commitcf9a1e3c7d4c6a0916b85960a6dffc1d67319f1e (patch)
tree3b37b4806dad1fa57474ebd08871d60cb4f16269 /runtimes/CMakeLists.txt
parentc96b33c2f4eedc8cd21607b2cc43a5e579f8c7e9 (diff)
[CMake] Expose runtime component check targets
This will expose the check targets for runtime project components into the top-level build. It will enable exposing targets like check-asan. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@279861 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 789a93c7e1f..139f6034e13 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -153,6 +153,9 @@ else() # if this is included from LLVM's CMake
if(LLVM_INCLUDE_TESTS)
set(test_targets runtimes-test-depends check-runtimes)
+ foreach(component ${SUB_COMPONENTS})
+ list(APPEND SUB_COMPONENT_CHECK_TARGETS check-${component})
+ endforeach()
endif()
# Create a runtimes target that uses this file as its top-level CMake file.
@@ -168,6 +171,7 @@ else() # if this is included from LLVM's CMake
EXTRA_TARGETS ${extra_targets}
${test_targets}
${SUB_COMPONENTS}
+ ${SUB_COMPONENT_CHECK_TARGETS}
${SUB_INSTALL_TARGETS}
USE_TOOLCHAIN)
if(LLVM_INCLUDE_TESTS)