summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorLeo Li <aoli@google.com>2017-07-24 17:26:28 +0000
committerLeo Li <aoli@google.com>2017-07-24 17:26:28 +0000
commitc37f42c5b84a6c9292e659502cf3c87634c4d0bf (patch)
tree0dfad8409cffca26656ea8e35918fa21fb204a1d /runtimes/CMakeLists.txt
parentd5395f15ca10e773e47a08c9a0404b487f0c3e2a (diff)
[CMake] Remove redundant logic in runtimes/CMakeList.txt
Summary: `SUB_CHECK_TARGETS` contains all test targets in `SUB_COMPONENTS` when we load `Components.cmake`. We don't need to add those targets again and having duplicate targets will break the cmake policy CMP0002. Reviewers: phosek Subscribers: mgorny, llvm-commits, srhines, pirama Differential Revision: https://reviews.llvm.org/D35692 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@308900 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index f475878e2f2..14c87358e70 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -367,9 +367,6 @@ else() # if this is included from LLVM's CMake
if(LLVM_INCLUDE_TESTS)
list(APPEND test_targets runtimes-test-depends check-runtimes)
- foreach(component ${SUB_COMPONENTS})
- list(APPEND SUB_CHECK_TARGETS check-${component})
- endforeach()
endif()
llvm_ExternalProject_Add(runtimes