summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-11-17 23:51:53 +0000
committerPetr Hosek <phosek@chromium.org>2017-11-17 23:51:53 +0000
commit8e87d92d1dfcde8e342148d4c442eaa5d8a536f1 (patch)
treeef349dbc3c1776c6afbc7b22df667866062e5313 /runtimes/CMakeLists.txt
parentcf9af88805cf0d5a7957e6634ad4255d3f28d500 (diff)
[CMake][runtimes] Don't passthrough prefixes for non-default targets
The passthrough is useful for setting up the options for the default build, but we already have a different mechanism to pass CMake flags to builds for builtins and runtimes targets so this is not really needed there. Furthermore, when the flags are set for the default build, with the prefix passthrough set we have to explicitly override all options in other targets which can be cumbersome. Differential Revision: https://reviews.llvm.org/D39988 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@318571 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 3a2f894dfa6..67d60b0b6a4 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -247,7 +247,6 @@ else() # if this is included from LLVM's CMake
-DCOMPILER_RT_DEFAULT_TARGET_ONLY=ON
${${target}_extra_args}
TOOLCHAIN_TOOLS clang lld llvm-ar llvm-ranlib
- PASSTHROUGH_PREFIXES COMPILER_RT
USE_TOOLCHAIN
${EXTRA_ARGS})
endfunction()