summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-01-10 19:47:05 +0000
committerPetr Hosek <phosek@chromium.org>2017-01-10 19:47:05 +0000
commit8548be38d13b6aafb361efffb8e621618b0d50e3 (patch)
tree427087ea1397a5ee953a8ac33d08012f0baf2e9d /runtimes/CMakeLists.txt
parentc7eb5df9be401ee84f6ce04691f72e9ff97a2075 (diff)
[CMake] Handle common options for runtimes build
All the existing runtimes relies on flags which are set by AddLLVM and HandleLLVMOptions. In the standalone case, they would include these themselves, but when being built using LLVM runtimes we should include these in the top-level runtimes CMake files. Differential Revision: https://reviews.llvm.org/D28389 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@291590 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index bf802a3b4ea..f5d16952b40 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -61,6 +61,10 @@ if(${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR})
# This variable makes sure that e.g. llvm-lit is found.
set(LLVM_MAIN_SRC_DIR ${LLVM_BUILD_MAIN_SRC_DIR})
+ # Handle common options used by all runtimes.
+ include(AddLLVM)
+ include(HandleLLVMOptions)
+
foreach(entry ${runtimes})
get_filename_component(projName ${entry} NAME)