summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-09-01 18:26:01 +0000
committerChris Bieneman <beanz@apple.com>2016-09-01 18:26:01 +0000
commit816c475854dec29de608c4e76beb27ee4f813f6c (patch)
tree5afb383e0351af49fdac7ecd37f9f11609bb14ac /runtimes/CMakeLists.txt
parentadd0a5d6febdb1f5356b7af435c571c89c2f9725 (diff)
[CMake] Connecting check-all and test-depends targets correctly
My previous attempt at this connected the sub-project check targets to the test-depends target instead of to the check-all target. That resulted in the tests running multiple times on bots that built "test-depends" and "check-all" in separate build invocations. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@280392 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 0ffffd6fbfe..e43ea74e00f 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -194,7 +194,8 @@ else() # if this is included from LLVM's CMake
${SUB_INSTALL_TARGETS}
USE_TOOLCHAIN)
if(LLVM_INCLUDE_TESTS)
- set_property(GLOBAL APPEND PROPERTY LLVM_LIT_DEPENDS runtimes-test-depends)
+ set_property(GLOBAL APPEND PROPERTY LLVM_ADDITIONAL_TEST_DEPENDS runtimes-test-depends)
+ set_property(GLOBAL APPEND PROPERTY LLVM_ADDITIONAL_TEST_TARGETS check-runtimes)
endif()
endif()
endif()