summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-08-29 20:18:52 +0000
committerChris Bieneman <beanz@apple.com>2016-08-29 20:18:52 +0000
commit6aad1fb5e9720ab389bda5ff330d3bf4561fe6ca (patch)
tree73a513eacb7ba6a9c1e1f83c88048a28776750e3 /runtimes/CMakeLists.txt
parent1254de0c5c05324c9cb0298b74c2be734b90aa29 (diff)
[CMake] Builtins build needs LLVM_*_OUTPUT_INTDIR variables
This allows the builtins archives to build into the correct subdirectory under the binary dir. Addresses the issue discussed in D24001. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@280002 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 4d0747680a4..a787fc9b5b7 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -123,6 +123,8 @@ else() # if this is included from LLVM's CMake
if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt)
llvm_ExternalProject_Add(builtins
${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt/lib/builtins
+ CMAKE_ARGS -DLLVM_LIBRARY_OUTPUT_INTDIR=${LLVM_LIBRARY_DIR}
+ -DLLVM_RUNTIME_OUTPUT_INTDIR=${LLVM_TOOLS_BINARY_DIR}
PASSTHROUGH_PREFIXES COMPILER_RT
USE_TOOLCHAIN)
set(deps builtins)