summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-08-18 22:18:11 +0000
committerChris Bieneman <beanz@apple.com>2016-08-18 22:18:11 +0000
commit67f56cc4e419e85e61d736d577caf3f311823fe6 (patch)
treebcb5695ebc58396b7eba88034ad2b0fe22cde28c /runtimes/CMakeLists.txt
parent664ab5e536e47b7b942d66563a8293e657c10c0e (diff)
[CMake] Add variables for tracking which runtimes are included
This allows sub-projects to have conditionals based on the presence of other projects. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@279172 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 3f9febc385a..bbdebff2e5e 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -48,6 +48,10 @@ if(${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR})
# The subdirectories need to treat this as standalone builds
set(${canon_name}_STANDALONE_BUILD On)
+ # Setting a variable to let sub-projects detect which other projects
+ # will be included under here.
+ set(HAVE_${canon_name} On)
+
add_subdirectory(${projName})
endforeach()