summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-09-02 02:28:03 +0000
committerPetr Hosek <phosek@chromium.org>2017-09-02 02:28:03 +0000
commit4f10103672ff84759c4d2c1e675f04149b21366c (patch)
tree8a17bf906a900af84de086f731c0fac8e13ca6f2 /runtimes/CMakeLists.txt
parent026a351310bc0f3fab2594070e7150f47d207691 (diff)
[CMake][runtimes] Use target specific name for all runtimes targets
We need to use target specific name for all runtimes targets. Target specific name means the name of target in the LLVM build is different from the name in runtimes build (in LLVM build, it's suffixed by the target itself). Previously we have only used target specific names for check targets collected through SUB_CHECK_TARGETS, but that's not sufficient, we need to use target specific names for all targets we're exposing in LLVM build. Fixes PR34335. Differential Revision: https://reviews.llvm.org/D37245 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@312405 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 9ae755361ed..0af7c47e6fe 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -306,22 +306,24 @@ else() # if this is included from LLVM's CMake
foreach(runtime_name ${runtime_names})
list(APPEND ${name}_extra_targets
- ${runtime_name}-${name}
- install-${runtime_name}-${name})
+ "${runtime_name}:${runtime_name}-${name}"
+ "install-${runtime_name}:install-${runtime_name}-${name}")
if(LLVM_INCLUDE_TESTS)
- list(APPEND ${name}_test_targets check-${runtime_name}-${name})
+ list(APPEND ${name}_test_targets "check-${runtime_name}:check-${runtime_name}-${name}")
endif()
endforeach()
- foreach(name IN LISTS SUB_COMPONENTS SUB_INSTALL_TARGETS)
- list(APPEND ${name}_extra_targets "${name}:${name}-${name}")
+ foreach(target_name IN LISTS SUB_COMPONENTS SUB_INSTALL_TARGETS)
+ list(APPEND ${name}_extra_targets "${target_name}:${target_name}-${name}")
endforeach()
if(LLVM_INCLUDE_TESTS)
- list(APPEND ${name}_test_targets runtimes-test-depends-${name} check-runtimes-${name})
+ list(APPEND ${name}_test_targets
+ "runtimes-test-depends:runtimes-test-depends-${name}"
+ "check-runtimes:check-runtimes-${name}")
foreach(target_name IN LISTS SUB_CHECK_TARGETS)
list(APPEND ${name}_test_targets "${target_name}:${target_name}-${name}")
- list(APPEND test_targets ${target_name}-${name})
+ list(APPEND test_targets "${target_name}-${name}")
endforeach()
set(test_targets "${test_targets}" PARENT_SCOPE)
endif()