summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-10-19 21:50:25 +0000
committerChris Bieneman <beanz@apple.com>2016-10-19 21:50:25 +0000
commit43fa064b8cfe5be1b710293b4b4239569808af17 (patch)
tree0d5e352bbff604d9c67cec353db26b172dc7f66e /runtimes/CMakeLists.txt
parentbac9c437ae55334028596f0e54d74be2ec04d15d (diff)
[CMake] Make the runtimes directory work with bootstrap builds
This patch builds on clang r284648, and allows the runtime directory to make the bootstrap builds depend on the builtin libraries. This patch also make the bootstrap build depend on configuring the other runtimes because the libcxx headers are copied during configuration. I have left a TODO in the code to remove that once I come up with a better solution. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@284650 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index 2974726a7f7..3b059062c17 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -146,6 +146,11 @@ else() # if this is included from LLVM's CMake
PASSTHROUGH_PREFIXES COMPILER_RT
USE_TOOLCHAIN)
set(deps builtins)
+ # We don't need to depend on the builtins if we're building instrumented
+ # because the next stage will use the same compiler used to build this stage.
+ if(NOT LLVM_BUILD_INSTRUMENTED AND CLANG_ENABLE_BOOTSTRAP)
+ add_dependencies(clang-bootstrap-deps builtins)
+ endif()
endif()
# We create a list the names of all the runtime projects in all uppercase and
@@ -196,6 +201,16 @@ else() # if this is included from LLVM's CMake
${SUB_COMPONENT_CHECK_TARGETS}
${SUB_INSTALL_TARGETS}
USE_TOOLCHAIN)
+
+ # TODO: This is a hack needed because the libcxx headers are copied into the
+ # build directory during configuration. Without that step the clang in the
+ # build directory cannot find the C++ headers in certain configurations.
+ # I need to build a mechanism for runtime projects to provide CMake code
+ # that executes at LLVM configuration time to handle this case.
+ if(NOT LLVM_BUILD_INSTRUMENTED AND CLANG_ENABLE_BOOTSTRAP)
+ add_dependencies(clang-bootstrap-deps runtimes-configure)
+ endif()
+
if(LLVM_INCLUDE_TESTS)
set_property(GLOBAL APPEND PROPERTY LLVM_ADDITIONAL_TEST_DEPENDS runtimes-test-depends)
set_property(GLOBAL APPEND PROPERTY LLVM_ADDITIONAL_TEST_TARGETS check-runtimes)