summaryrefslogtreecommitdiff
path: root/runtimes/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-08-18 21:47:18 +0000
committerChris Bieneman <beanz@apple.com>2016-08-18 21:47:18 +0000
commit26b922023e48c0c910961648994bfe8d8c11a09b (patch)
treee24119bf82f46f6c5efa3318b06018a38474e4e2 /runtimes/CMakeLists.txt
parent99174eb706a611eae6c9b5db0f9bacd80bc5ac80 (diff)
[CMake] Create convenience targets for runtime projects
Each runtime project has a top-level target that is the name of the runtime (minus the "lib" prefix if applicable). This creates top-level targets mapping to runtime projects. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@279160 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtimes/CMakeLists.txt')
-rw-r--r--runtimes/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/runtimes/CMakeLists.txt b/runtimes/CMakeLists.txt
index a155cacb75b..3f9febc385a 100644
--- a/runtimes/CMakeLists.txt
+++ b/runtimes/CMakeLists.txt
@@ -73,6 +73,12 @@ else() # if this is included from LLVM's CMake
string(REPLACE "-" "_" canon_name ${projName})
string(TOUPPER ${canon_name} canon_name)
list(APPEND prefixes ${canon_name})
+
+ string(FIND ${projName} "lib" LIB_IDX)
+ if(LIB_IDX EQUAL 0)
+ string(SUBSTRING ${projName} 3 -1 projName)
+ endif()
+ list(APPEND runtime_names ${projName})
endforeach()
if(runtimes)
@@ -85,6 +91,7 @@ else() # if this is included from LLVM's CMake
# Builtins were built separately above
CMAKE_ARGS -DCOMPILER_RT_BUILD_BUILTINS=Off
PASSTHROUGH_PREFIXES ${prefixes}
+ EXTRA_TARGETS ${runtime_names}
USE_TOOLCHAIN)
endif()
endif()