summaryrefslogtreecommitdiff
path: root/projects/CMakeLists.txt
diff options
context:
space:
mode:
authorPirama Arumuga Nainar <pirama@google.com>2017-03-07 18:54:17 +0000
committerPirama Arumuga Nainar <pirama@google.com>2017-03-07 18:54:17 +0000
commitbeecea156f1623cf190db326b9a6d525d646c512 (patch)
tree6dc0ff28888a08efe76832af2b90213ea70db5e8 /projects/CMakeLists.txt
parentda6d07a9655ab5f81eb5b3133d937a7c0877b9e9 (diff)
[cmake] Include openmp with add_llvm_external_project
Summary: Include projects/openmp into the build using add_llvm_external_project instead of add_subdirectory. This creates an option LLVM_TOOL_OPENMP_BUILD that selects whether this project gets included in an in-tree build. Reviewers: beanz, AndreyChurbanov, jlpeyton Subscribers: srhines, openmp-commits, llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D30470 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@297185 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'projects/CMakeLists.txt')
-rw-r--r--projects/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/projects/CMakeLists.txt b/projects/CMakeLists.txt
index 2122665c0dc..79d8fc7df99 100644
--- a/projects/CMakeLists.txt
+++ b/projects/CMakeLists.txt
@@ -10,7 +10,8 @@ foreach(entry ${entries})
(NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxxabi) AND
(NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libunwind) AND
(NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/test-suite) AND
- (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/parallel-libs))
+ (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/parallel-libs) AND
+ (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/openmp))
add_subdirectory(${entry})
endif()
endif()
@@ -35,3 +36,4 @@ endif()
add_llvm_external_project(dragonegg)
add_llvm_external_project(parallel-libs)
+add_llvm_external_project(openmp)