summaryrefslogtreecommitdiff
path: root/projects/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-05-11 01:44:30 +0000
committerEric Fiselier <eric@efcs.ca>2017-05-11 01:44:30 +0000
commit895dd414136b314ba62e2e181cce73bd4cab569d (patch)
tree193a59ead9ff49b989d5670e5a14c6d5f7867040 /projects/CMakeLists.txt
parent3e0a9ecbab14315d9cbb86c56c2b2f014ae315f9 (diff)
Add temporary workaround to allow in-tree libc++ builds on Windows
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@302753 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'projects/CMakeLists.txt')
-rw-r--r--projects/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/projects/CMakeLists.txt b/projects/CMakeLists.txt
index 79d8fc7df99..9102efbdcb4 100644
--- a/projects/CMakeLists.txt
+++ b/projects/CMakeLists.txt
@@ -22,7 +22,9 @@ endforeach(entry)
if(${LLVM_BUILD_RUNTIME})
# MSVC isn't quite working with libc++ yet, disable it until issues are
# fixed.
- if(NOT MSVC)
+ # FIXME: LLVM_FORCE_BUILD_RUNTIME is currently used by libc++ to force
+ # enable the in-tree build when targeting clang-cl.
+ if(NOT MSVC OR LLVM_FORCE_BUILD_RUNTIME)
# Add the projects in reverse order of their dependencies so that the
# dependent projects can see the target names of their dependencies.
add_llvm_external_project(libunwind)