summaryrefslogtreecommitdiff
path: root/lib/Target/RISCV/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Bradbury <asb@lowrisc.org>2017-10-19 21:37:38 +0000
committerAlex Bradbury <asb@lowrisc.org>2017-10-19 21:37:38 +0000
commit5a3d179fab70138a1cb63a8d7c4a407dbb7dba6e (patch)
treee50f04a5ea2113534abebbd84e3300b3c5dc5982 /lib/Target/RISCV/CMakeLists.txt
parentab16d0abcd68c515720e0da86db48e36db562d3f (diff)
[RISCV] Initial codegen support for ALU operations
This adds the minimum necessary to support codegen for simple ALU operations on RV32. Prolog and epilog insertion, support for memory operations etc etc follow in future patches. Leave guessInstructionProperties=1 until https://reviews.llvm.org/D37065 is reviewed and lands. Differential Revision: https://reviews.llvm.org/D29933 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@316188 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/RISCV/CMakeLists.txt')
-rw-r--r--lib/Target/RISCV/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/Target/RISCV/CMakeLists.txt b/lib/Target/RISCV/CMakeLists.txt
index b9f3fc110c7..bac4d4c353d 100644
--- a/lib/Target/RISCV/CMakeLists.txt
+++ b/lib/Target/RISCV/CMakeLists.txt
@@ -3,14 +3,25 @@ set(LLVM_TARGET_DEFINITIONS RISCV.td)
tablegen(LLVM RISCVGenRegisterInfo.inc -gen-register-info)
tablegen(LLVM RISCVGenInstrInfo.inc -gen-instr-info)
tablegen(LLVM RISCVGenMCCodeEmitter.inc -gen-emitter)
+tablegen(LLVM RISCVGenMCPseudoLowering.inc -gen-pseudo-lowering)
tablegen(LLVM RISCVGenAsmMatcher.inc -gen-asm-matcher)
tablegen(LLVM RISCVGenAsmWriter.inc -gen-asm-writer)
+tablegen(LLVM RISCVGenCallingConv.inc -gen-callingconv)
+tablegen(LLVM RISCVGenDAGISel.inc -gen-dag-isel)
tablegen(LLVM RISCVGenSubtargetInfo.inc -gen-subtarget)
tablegen(LLVM RISCVGenDisassemblerTables.inc -gen-disassembler)
add_public_tablegen_target(RISCVCommonTableGen)
add_llvm_target(RISCVCodeGen
+ RISCVAsmPrinter.cpp
+ RISCVFrameLowering.cpp
+ RISCVInstrInfo.cpp
+ RISCVISelDAGToDAG.cpp
+ RISCVISelLowering.cpp
+ RISCVMCInstLower.cpp
+ RISCVRegisterInfo.cpp
+ RISCVSubtarget.cpp
RISCVTargetMachine.cpp
)