summaryrefslogtreecommitdiff
path: root/lib/Target/PowerPC/CMakeLists.txt
diff options
context:
space:
mode:
authorHal Finkel <hfinkel@anl.gov>2012-06-08 15:38:21 +0000
committerHal Finkel <hfinkel@anl.gov>2012-06-08 15:38:21 +0000
commit99f823f94374917174f96a7689955b8463db6816 (patch)
treeb9e21d1fb7674ec9e130e22ece338dccfc24ddd2 /lib/Target/PowerPC/CMakeLists.txt
parent69938a85bdbeef1c5b60aa778e361586bec36fb7 (diff)
Add the PPCCTRLoops pass: a PPC machine-code-level optimization pass to form CTR-based loop branching code.
This pass is derived from the Hexagon HardwareLoops pass. The only significant enhancement over the Hexagon pass is that PPCCTRLoops will also attempt to delete the replaced add and compare operations if they are no longer otherwise used. Also, invalid preheader DebugLoc is not used. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@158204 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/PowerPC/CMakeLists.txt')
-rw-r--r--lib/Target/PowerPC/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/PowerPC/CMakeLists.txt b/lib/Target/PowerPC/CMakeLists.txt
index bcd8bd29162..7204926526b 100644
--- a/lib/Target/PowerPC/CMakeLists.txt
+++ b/lib/Target/PowerPC/CMakeLists.txt
@@ -14,6 +14,7 @@ add_llvm_target(PowerPCCodeGen
PPCAsmPrinter.cpp
PPCBranchSelector.cpp
PPCCodeEmitter.cpp
+ PPCCTRLoops.cpp
PPCHazardRecognizers.cpp
PPCInstrInfo.cpp
PPCISelDAGToDAG.cpp