summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2015-01-15 02:16:27 +0000
committerChandler Carruth <chandlerc@gmail.com>2015-01-15 02:16:27 +0000
commitbda134910ab021c647ed05bfba8176cba4696c82 (patch)
tree8c53b77bf126fed94ad8dc3f2da62b2082aeff46 /lib/Target/CMakeLists.txt
parent635656e23174cea675e9d4352c43143129740b5e (diff)
[PM] Move TargetLibraryInfo into the Analysis library.
While the term "Target" is in the name, it doesn't really have to do with the LLVM Target library -- this isn't an abstraction which LLVM targets generally need to implement or extend. It has much more to do with modeling the various runtime libraries on different OSes and with different runtime environments. The "target" in this sense is the more general sense of a target of cross compilation. This is in preparation for porting this analysis to the new pass manager. No functionality changed, and updates inbound for Clang and Polly. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@226078 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index c61805b63f5..87162dc5bf7 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -1,7 +1,6 @@
add_llvm_library(LLVMTarget
Target.cpp
TargetIntrinsicInfo.cpp
- TargetLibraryInfo.cpp
TargetLoweringObjectFile.cpp
TargetMachine.cpp
TargetMachineC.cpp