summaryrefslogtreecommitdiff
path: root/lib/LTO/CMakeLists.txt
diff options
context:
space:
mode:
authorMehdi Amini <mehdi.amini@apple.com>2016-03-09 01:37:22 +0000
committerMehdi Amini <mehdi.amini@apple.com>2016-03-09 01:37:22 +0000
commit73cf01b19365604fd2f835379e4b5afb7ef02db6 (patch)
treeb344bebf2bad2e77e638b543b580f428ef844bcc /lib/LTO/CMakeLists.txt
parentec57137c985ab7da95b16d32b3ed0c65e99140b4 (diff)
libLTO: add a ThinLTOCodeGenerator on the model of LTOCodeGenerator.
This is intended to provide a parallel (threaded) ThinLTO scheme for linker plugin use through the libLTO C API. The intent of this patch is to provide a first implementation as a proof-of-concept and allows linker to start supporting ThinLTO by definiing the libLTO C API. Some part of the libLTO API are left unimplemented yet. Following patches will add support for these. The current implementation can link all clang/llvm binaries. Differential Revision: http://reviews.llvm.org/D17066 From: Mehdi Amini <mehdi.amini@apple.com> git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@262977 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/LTO/CMakeLists.txt')
-rw-r--r--lib/LTO/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/LTO/CMakeLists.txt b/lib/LTO/CMakeLists.txt
index 1c099bb029b..bd8ead1b2c5 100644
--- a/lib/LTO/CMakeLists.txt
+++ b/lib/LTO/CMakeLists.txt
@@ -1,9 +1,10 @@
add_llvm_library(LLVMLTO
LTOModule.cpp
LTOCodeGenerator.cpp
+ ThinLTOCodeGenerator.cpp
ADDITIONAL_HEADER_DIRS
${LLVM_MAIN_INCLUDE_DIR}/llvm/LTO
- )
+)
add_dependencies(LLVMLTO intrinsics_gen)