summaryrefslogtreecommitdiff
path: root/lib/IR/CMakeLists.txt
diff options
context:
space:
mode:
authorTeresa Johnson <tejohnson@google.com>2015-10-04 14:33:43 +0000
committerTeresa Johnson <tejohnson@google.com>2015-10-04 14:33:43 +0000
commitb97baa5fe54954247e143e702201364284b54345 (patch)
treef9a0439d30b6361bc32da8a88e5d343cfb0c1bb9 /lib/IR/CMakeLists.txt
parentea978bb5631cd8dce5af87a2678750936a90d40c (diff)
Support for function summary index bitcode sections and files.
Summary: The bitcode format is described in this document: https://drive.google.com/file/d/0B036uwnWM6RWdnBLakxmeDdOeXc/view For more info on ThinLTO see: https://sites.google.com/site/llvmthinlto The first customer is ThinLTO, however the data structures are designed and named more generally based on prior feedback. There are a few comments regarding how certain interfaces are used by ThinLTO, and the options added here to gold currently have ThinLTO-specific names as the behavior they provoke is currently ThinLTO-specific. This patch includes support for generating per-module function indexes, the combined index file via the gold plugin, and several tests (more are included with the associated clang patch D11908). Reviewers: dexonsmith, davidxl, joker.eph Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D13107 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@249270 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/IR/CMakeLists.txt')
-rw-r--r--lib/IR/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/IR/CMakeLists.txt b/lib/IR/CMakeLists.txt
index 9bc44570734..472178f5122 100644
--- a/lib/IR/CMakeLists.txt
+++ b/lib/IR/CMakeLists.txt
@@ -39,6 +39,7 @@ add_llvm_library(LLVMCore
PassManager.cpp
PassRegistry.cpp
Statepoint.cpp
+ FunctionInfo.cpp
Type.cpp
TypeFinder.cpp
Use.cpp