summaryrefslogtreecommitdiff
path: root/lib/IR/CMakeLists.txt
diff options
context:
space:
mode:
authorAkira Hatanaka <ahatanaka@apple.com>2015-12-22 20:00:05 +0000
committerAkira Hatanaka <ahatanaka@apple.com>2015-12-22 20:00:05 +0000
commita4912f57559181c6ba848114c6e524fe62368fcb (patch)
tree8dc5f7acc3ebb177a4e7a604cd472e42377f3e4d /lib/IR/CMakeLists.txt
parent937ba4cad8c9d5c8d5d2de06e535299a85ff42c6 (diff)
Provide a way to specify inliner's attribute compatibility and merging.
This reapplies r252990 and r252949. I've added member function getKind to the Attr classes which returns the enum or string of the attribute. Original commit message for r252949: Provide a way to specify inliner's attribute compatibility and merging rules using table-gen. NFC. This commit adds new classes CompatRule and MergeRule to Attributes.td, which are used to generate code to check attribute compatibility and merge attributes of the caller and callee. rdar://problem/19836465 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@256277 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/IR/CMakeLists.txt')
-rw-r--r--lib/IR/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/IR/CMakeLists.txt b/lib/IR/CMakeLists.txt
index 472178f5122..eb67c525ce2 100644
--- a/lib/IR/CMakeLists.txt
+++ b/lib/IR/CMakeLists.txt
@@ -1,3 +1,7 @@
+set(LLVM_TARGET_DEFINITIONS AttributesCompatFunc.td)
+tablegen(LLVM AttributesCompatFunc.inc -gen-attrs)
+add_public_tablegen_target(AttributeCompatFuncTableGen)
+
add_llvm_library(LLVMCore
AsmWriter.cpp
Attributes.cpp