summaryrefslogtreecommitdiff
path: root/lib/IR/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2015-12-29 02:14:50 +0000
committerChandler Carruth <chandlerc@gmail.com>2015-12-29 02:14:50 +0000
commit9bdbabc1b2875e6a7dd5d5e0702c6570d2aacbbf (patch)
tree07f7b6b87dba4a0494fe41f7f03bf39feb3af259 /lib/IR/CMakeLists.txt
parent5c35f963fb19dbd9961d8df73a4e3cdf1fd219fd (diff)
[ptr-traits] Merge the MetadataTracking helpers into the Metadata
header. This is part of a series of patches to allow LLVM to check for complete pointee types when computing its pointer traits. This is absolutely necessary to get correct (or reproducible) results for things like how many low bits are guaranteed to be zero. The MetadataTracking helpers aren't actually independent. They rely on constructing a PointerUnion between Metadata and MetadataAsValue pointers, which requires know the alignment of pointers to those types which requires them to be complete. The .cpp file even defined a method declared in Metadata.h! These really don't seem like something that is separable, and there is no real layering problem with just placing them together. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@256531 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/IR/CMakeLists.txt')
-rw-r--r--lib/IR/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/IR/CMakeLists.txt b/lib/IR/CMakeLists.txt
index eb67c525ce2..40b4ec65e22 100644
--- a/lib/IR/CMakeLists.txt
+++ b/lib/IR/CMakeLists.txt
@@ -36,7 +36,6 @@ add_llvm_library(LLVMCore
MDBuilder.cpp
Mangler.cpp
Metadata.cpp
- MetadataTracking.cpp
Module.cpp
Operator.cpp
Pass.cpp