summaryrefslogtreecommitdiff
path: root/lib/Fuzzer/test/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Serebryany <kcc@google.com>2017-07-20 00:37:08 +0000
committerKostya Serebryany <kcc@google.com>2017-07-20 00:37:08 +0000
commit6c825738bb037c380ad64c91de68b35a9c27a015 (patch)
tree5beb758fe6dd04ed975498175a03fd539b241c58 /lib/Fuzzer/test/CMakeLists.txt
parent6d0a7e6ddcc48f8a4c67fb492decf0bf4da81d67 (diff)
[libFuzzer] add DeepRecursionTest, inspired by https://guidovranken.wordpress.com/2017/07/08/libfuzzer-gv-new-techniques-for-dramatically-faster-fuzzing/ (Stack-depth-guided fuzzing). libFuzzer does not solve it yet.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@308571 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Fuzzer/test/CMakeLists.txt')
-rw-r--r--lib/Fuzzer/test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Fuzzer/test/CMakeLists.txt b/lib/Fuzzer/test/CMakeLists.txt
index 28de8dc725d..99ca926a51e 100644
--- a/lib/Fuzzer/test/CMakeLists.txt
+++ b/lib/Fuzzer/test/CMakeLists.txt
@@ -86,6 +86,7 @@ set(Tests
CustomCrossOverTest
CustomMutatorTest
CxxStringEqTest
+ DeepRecursionTest
DivTest
EmptyTest
EquivalenceATest